Grenier, boite 1

Les articles ci-dessous ont été récupérés d’un site “Cours Windev” qui a disparu d’internet (ATTENTION : ne pas tenter d’aller sur http://www.courswindev.com, la page qui persiste donne des alertes de sécurité). Seuls les contenus présentant un intérêt sont ici proposés.  Merci à son auteur Mouhcin !

Déplacer les boutons en temps réel Windev

Déclaration globale

V_X , V_Y est un réel  
V est un booléen=0  
 btn_encour est une chaîne

Fenêtre Survol

V_X=SourisPosX()  
V_Y=SourisPosY()

Procédure

PROCEDURE Deplacer()  
TANTQUE V  
   Multitâche(-2)  
   {btn_encour,indChamp}..X=V_X  
   {btn_encour,indChamp}..Y=V_Y  
FIN

Clic sur le Bouton

SI V ALORS  
   V=Faux  
   ThreadArrête("TH")  
SINON  
   V=Vrai  
   btn_encour=MoiMême..Nom  
   ThreadExécute("TH",threadNormal,Deplacer)  
FIN

Récupérer un code-barre via le port série

Pour lire un code-barres à l’aide d’un appareil spécialisé :

  1. Branchez un appareil spécialisé sur le port série de votre machine
  2. Selon l’appareil utilisé, vérifiez que le clavier n’est pas en majuscules, et/ou que l’appareil est configuré pour un clavier français
  3. Récupérez la valeur du code-barres lue grâce aux fonctions de gestion des ports série suivantes :
    1. sOuvre, qui permet d’ouvrir et d’initialiser le port série (ou le port parallèle) spécifié.
    2. sLit, qui lit une chaîne de caractères dans le buffer d’entrée du port série spécifié.

Procédure

PROCEDURE CodeRead(COM)  
nPortSérie est un entier =COM
SI PAS sOuvre(nPortSérie, 13, 5000) ALORS   
   Erreur("Erreur d'ouvrir le port COM"+COM);RETOUR  
FIN  
TANTQUE Vrai  
   Nb_len est un entier = 13   
   Resultat_Len est un entier   
   Resultat est une chaîne   
   Resultat_Len = sDansFileEntrée(nPortSérie)   
   SI Resultat_Len >= Nb_len ALORS  
      Resultat = sLit(nPortSérie,Resultat_Len)   
      Resultat = Remplace(Resultat,Caract(13),"") // Caract(13)+Caract(10) = Retour Chariot  
      Resultat = Remplace(Resultat,Caract(10),"")  
      // Traitement de la recherche dans la base de donne   
      // Exemple :   
      //           1 : HLitRecherche(Article,code,Resultat,hIdentique)  
      //           2 : select * from article where code='"+Resultat+"'  
   FIN  
FIN

Appel de procédure

ThreadExécute("hread_Code",threadNormal,"CodeRead",2) // Port série COM2

Sauvegarder une base de données HFSQL


Bouton [Se connecter]

// Paramètres de la connexion  
 DB_connexion..Provider = hAccèsHFClientServeur  
 DB_connexion..Utilisateur = sai_Utilisateur  
 DB_connexion..MotDePasse = sai_passe  
 DB_connexion..Serveur = sai_Serveur+":"+sai_Port  
 DB_connexion..Cryptage = hCryptageNon  
 SI HOuvreConnexion(DB_connexion) ALORS 
    ListeSupprimeTout(Combo_ListeDB)
    soit liste=HListeBaseDeDonnées(DB_connexion,hLstNormal)  
    ListeSupprimeTout(Combo_ListeDB)  
    POUR TOUTE CHAÎNE DB DE liste  
       ListeAjoute(Combo_ListeDB,DB+gLien(DB))  
    FIN   
    Groupe_Sauvegarde..Etat=Actif       
 FIN

Bouton [Sauvegarder]

QUAND EXCEPTION DANS  
   HSauvegarde(DB_connexion,Combo_ListeDB,sai_rep,Int_index,sai_description,Jauge1)  
FAIRE  
   Lib_erreur=ErreurInfo(errRésumé)  
FIN

PS : les sources ne sont plus disponibles

HFSQL Viewer - Visualiser le contenu d'un Fichier HFSQL

HF Viewer permet de visualiser le contenu d’un fichier au format HFSQL Classic ou HFSQL Client/Serveur. HF Viewer peut être lancé par clic droit sur un fichier ‘.FIC’.

Cocher “Ajouter au menu contextuel” pour ajouter HF Viewer au menu clic droit de Windows

Sources HFSQL Viewer
PC-Info


Récupérer les information du système en utilisant le registre de Windows (RegistreLit) et la fonction SysEnvironnement :
Le nom de processeur

RegistreLit("HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0","ProcessorNameString")

La Fréquence de processeur

RegistreLit("HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0", "~MHz") + " Mhz"

Le système d’exploitation

RegistreLit("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion", "ProductName")

Le fabriquant de la carte mère

RegistreLit("HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\BIOS", "BaseBoardManufacturer")

L’utilisateur courant

ExtraitChaîne(SysEnvironnement("USERNAME"),2,"=")

Sources PC-Info

Accéder à HFSQL depuis Excel via ODBC

Le provider OLE DB pour HFSQL permet d’accéder à une base de données HFSQL (Classic ou Client/Serveur) depuis un logiciel externe gérant les accès par OLE DB. Le provider est disponible en lecture et en écriture. Une application écrite dans un langage tiers peut lire et écrire dans des fichiers HFSQL.

Transférer une base de données HyperFile vers une autre base/un autre serveur
Accéder à HFSQL depuis C# via ODBC

Le driver ODBC sur HFSQL Classic (monoposte et réseau) permet d’accéder à une base de données HFSQL Classic depuis un logiciel de base de données externe, gérant les accès par ODBC. Il est ainsi possible d’utiliser le driver ODBC sur HFSQL Classic via Visual .NET (en C#).

string connString = "DRIVER=HFSQL;Server Name=127.0.0.1;Server Port=4998;Database = 2017; UID = admin; PWD =";  
       OdbcConnection Connexion =  
               new OdbcConnection(connString);  
       Connexion.Open();  
       string Requete = "SELECT * FROM ville";  
       OdbcCommand Command = new OdbcCommand(Requete, Connexion);  
       OdbcDataReader DATA = Command.ExecuteReader();  
       while (DATA.Read())  
       {  
         dataGridView1.Rows.Add(DATA.GetInt32(0), DATA.GetString(1));  
       }

L’auteur a également publié “WinDev Faker” sur le dépôt de PC SOFT.
Sa chaîne Youtube avec 30 vidéos : https://www.youtube.com/channel/UC4deEr_ffeylO-VPN7Oaosg